Jump to content

Search the Community

Showing results for tags 'mitsubishi montero'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Car and Automotive Discussion
    • Car Comparisons & Shopping
    • American Manufacturers
    • Asian Manufacturers
    • European Manufacturers
    • Car Racing
    • After Market Parts and Electronics
    • Repairs & Maintenance
    • General Car Discussion
  • General Discussion
    • Off Topic
    • Gossip and News from the Industry
    • Introducing our Members
    • Site Related Discussion and News
  • Classifieds
    • Private: For Sale
    • Vendor: For Sale
    • Announcements

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests


Year


Model

Found 1 result

  1. Hello! This is my first time on a car forum, so bear with me! I’m having trouble starting my 1997 Mitsubishi Montero Sport in the cold. I’m in Alaska so the winters are really cold. At night it reaches the negatives. As far as I know, the previous owners didn’t have trouble starting it in the winter. Yesterday I put gas in my car and when I went to start the car it wouldn’t even try to crank. I got the car jumped later that day and it ran fine, just couldn’t turn it off until I was home. It has an almost brand new alternator and starter. I just put a brand new battery with 850 CCA in it last night. I plugged the block heater in, though I’m not positive that it’s working anymore. This morning I went to turn it on and it TRIED to crank but very slowly. Tried to jump it with an extra battery, nothing. I’m not sure if my starter might be extremely cold, engine is too cold, battery is too cold. I’m thinking I might need a battery jacket, but I’m not sure that that’ll fix the issue. Anything helps! Thank you!!
×
×
  • Create New...