Jump to content

Search the Community

Showing results for tags 'explorer'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Car and Automotive Discussion
    • Car Comparisons & Shopping
    • American Manufacturers
    • Asian Manufacturers
    • European Manufacturers
    • Car Racing
    • After Market Parts and Electronics
    • Repairs & Maintenance
    • General Car Discussion
  • General Discussion
    • Off Topic
    • Gossip and News from the Industry
    • Introducing our Members
    • Site Related Discussion and News
  • Classifieds
    • Private: For Sale
    • Vendor: For Sale
    • Announcements

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests


Year


Model

Found 2 results

  1. Good morning, I have a 2013 Ford Explorer 2WD 3.5L V6 with about 150k miles on it. It is currently reading OBDII codes P0430 and P0054 It is driving fine, no symptoms, other than the engine light being on. No loss of power or change in milage. What should I try first?
  2. I am a teenager, looking for a used either SUV, truck or sedan(Preferably a SUV or truck). I have up to $35k but I would love to keep it under $32k. I live in the Northeast so it needs to have AWD or 4WD. Also I don't like Asian cars, I just don't think they look nice. Reliability is not really an issue. Mostly looking for a car with good looks and good features. I've been mostly looking at 2012-2014 Grand Cherokees, Explorers and F-150s.
×
×
  • Create New...