Jump to content

Search the Community

Showing results for tags 'coolant leak'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Car and Automotive Discussion
    • Car Comparisons & Shopping
    • American Manufacturers
    • Asian Manufacturers
    • European Manufacturers
    • Car Racing
    • After Market Parts and Electronics
    • Repairs & Maintenance
    • General Car Discussion
  • General Discussion
    • Off Topic
    • Gossip and News from the Industry
    • Introducing our Members
    • Site Related Discussion and News
  • Classifieds
    • Private: For Sale
    • Vendor: For Sale
    • Announcements

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests


Year


Model

Found 1 result

  1. Hi everybody, I recently bought an 87 Suzuki Samurai. I've always thought they were cool and I've heard they are great cars to learn more about mechanics which is more the reason I bought it. I'm not that knowledgeable with mechanics yet so speak to me like I'm an idiot! Anyways, I've been fixing it up and learning a lot but now I've found some more major work that I'm not sure how to tackle. I think I may have a blown head gasket..but, I'm not sure. I'll list my cars symptoms below: -smoke from the exhaust at startup - stops after a few minutes of running -coolant in radiator starts bubbling with the lid off when I turn the car on - lots of tiny bubbles - coolant in the oil - not a ton but its there - milky sludge on the oil cap - loss of coolant, even when not running. I've stopped running it since noticing this leak. Seems to be internal, can't find any signs of exterior leakage. So, I've been doing some tests to try and isolate the problem and now I've confused myself.. I did a compression test. All 4 cylinders were consistent and within spec. The compression consistently rose slightly between a wet and dry test with all 4. I did a leak down test and, according to my tester, there wasn't much leakage. I thought for sure when I hooked up compressed air that I would get bubbling from the radiator cap but there was nothing.. I listened to the oil cap/dipstick, exhaust, intake and the radiator with the air hooked up. There was some air coming from the oil cap which I've heard is somewhat normal and could mean worn rings. My plan had been to get a gasket set and replace everything down to the head gasket but these tests have me confused. Why is my compression good and the leak down test came up fine? Could it possibly be a bad intake manifold/gasket? What else could it be? Or does someone think its still the head gasket? I've got a straight edge and feeler gauges so I'm going to check for warpage on the block/head when I take it apart. Other than that I'm not sure how to isolate and find the problem... Anyone have any thoughts on what is wrong with the engine? I'd love to have some more expert opinions before I attempt a pretty major job. Thanks everyone, Greg
×
×
  • Create New...