Jump to content
Sign in to follow this  
BMWguyincolorado123

2003 BMW radio not working

2 posts in this topic

Recommended Posts

i have a 2003 BMW X5 with the standard Business radio and CD player. No navigation. The radio display(on the radio screen) nor the sound works, but the lights on the buttons do which tells me i have power going to the radio and CD player. This happened on the old radio so I just got a brand new radio (Same exact radio but new) and same thing, the lights on the radio buttons work but the display does not come up nor does any sound work. I checked all the fuses and they're good so i cant seem to figure it out. Thanks! 

Share this post


Link to post
Share on other sites

 

 hello 😄I had the same problem. The main problem is that all modern head units work in parallel with the standard system regardless of whether it is Cis or Nbt. The first is to deal with the  sound. Please install Aux because the sound from new android head comes ONLY from AUX, Photos of my car attached. i just finished the same.

2.jpg

1.jpg

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  
- Back to Top -

×
×
  • Create New...