Jump to content
BroseGuapo

2011 Chrysler 200 Electrical Problems

3 posts in this topic

Recommended Posts

Hey Everyone,

I'm new to this site but figured it wouldn't hurt to come here and ask for advice or suggestions.

So my 200 started to have electrical problems. Dash lights started coming on and eventually gears wouldn't shift. I couldn't go past 15mph when driving it back to my parking lot. Alternator was recently changed about 3-4 years ago. Battery is still in good shape, but now it's to the point where the car wont even crank or turn over. It clicks when I try to start it. I've heard many suggestions that it's probably the starter but I have researched everywhere and can't seem to locate the starter. Anyone here have actual visual diagrams or pictures of how or where the starter is located? I've tried to locate it by following the positive cable of the battery but it has led me nowhere.. Feeling very clueless right now but I hope someone can help!

 

Thanks everyone.

Share this post


Link to post
Share on other sites

The starter relay is in the power distribution box in the engine compartment. It should be marked on the lid of the box.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
- Back to Top -

×
×
  • Create New...