Jump to content
Garrettw3

Amp and Radio help

2 posts in this topic

Recommended Posts

Hello I have a 2001 Chevy Suburban. I recently put an amp and sub in it and everything was working fine the sub was barely kicking so i decided to play with some of the stuff on my amp. well it kinda popped i guess thats the best way i can describe it? and in my old vehicle this would happen too once i turned my volume up loud enough. in my old truck i would turn it off and the amp would come back on and all would be good. but i turned my suburban off and the head unit kinda stayed on for a second and they turned off and now the head unit and amp wont come on. any help would be appreciated!

Share this post


Link to post
Share on other sites
14 hours ago, Garrettw3 said:

Hello I have a 2001 Chevy Suburban. I recently put an amp and sub in it and everything was working fine the sub was barely kicking so i decided to play with some of the stuff on my amp. well it kinda popped i guess thats the best way i can describe it? and in my old vehicle this would happen too once i turned my volume up loud enough. in my old truck i would turn it off and the amp would come back on and all would be good. but i turned my suburban off and the head unit kinda stayed on for a second and they turned off and now the head unit and amp wont come on. any help would be appreciated!

https://www.wikihow.com/Troubleshoot-an-Amp

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
- Back to Top -

×