Jump to content
Kous52

Trying to figure out my Dodge Avenger 2009 problems.

10 posts in this topic

Recommended Posts

This is my first car..ive owned it for about 4 years now. I keep up with rgular maintenance and all that. Well up until this year..i finally started having problems. Maybe two months ago..i started hearing this knocking/rattling noise at the front of my car..not sure its left, right, or middle. It only happens when i hit a pot hole or a bump. Its not super loud..ive gotta turn down my music or ac to hear it. Turning doesn't seem to make it worse. I figured it was a problem with my suspension system..but i cant pinpoint it exactly. Now another problem started today..its a vibration/flat tire sound..i can feel it in the tire well where i have my feet..drivers side. Not sure if the two problems are related but i'd like someone elses opinion. Cars are actually still pretty new to me..i'm learning. Has anyone else had the same problems? 

Share this post


Link to post
Share on other sites
10 hours ago, Kous52 said:

its a vibration/flat tire sound

That sounds in need of tire alignment. But nevertheless I'd have the suspension checked.

10 hours ago, Kous52 said:

Not sure if the two problems are related but i'd like someone elses opinion.

I don't think they are related....

Another way the tires become uneven is if the car sits in the same spot for months at a time...again if you drive often this shouldn't be a problem.

Share this post


Link to post
Share on other sites
1 hour ago, Nate4x4 said:

That sounds in need of tire alignment. But nevertheless I'd have the suspension checked.

I don't think they are related....

Another way the tires become uneven is if the car sits in the same spot for months at a time...again if you drive often this shouldn't be a problem.

I got brand new tires..with only about 5000 miles on it. Ive changed the front brakes and rotors last week.  I drove my car to work last morning and it didnt have the flat tire sound..but on the way to the store later that evening is when it appeared. I The longest my car has sat was about a week until yesterday.

Edited by Kous52

Share this post


Link to post
Share on other sites
3 hours ago, Kous52 said:

I got brand new tires..with only about 5000 miles on it. Ive changed the front brakes and rotors last week.  I drove my car to work last morning and it didnt have the flat tire sound..but on the way to the store later that evening is when it appeared. I The longest my car has sat was about a week until yesterday.

OK, so the tires are perfect.

That's strange. The only other thing I can think of would be the suspension.

Were you able to have it checked?

 

Share this post


Link to post
Share on other sites
58 minutes ago, Nate4x4 said:

OK, so the tires are perfect.

That's strange. The only other thing I can think of would be the suspension.

Were you able to have it checked?

 

I'm gonna get it checked this Friday..just wanted some ideas on what it could be..i looked up a few things about wheel bearings?

Share this post


Link to post
Share on other sites
30 minutes ago, Kous52 said:

I'm gonna get it checked this Friday..just wanted some ideas on what it could be..i looked up a few things about wheel bearings?

Awesome, I hope everything turns out for you.

Thanks for your question.👍

Nate

Share this post


Link to post
Share on other sites
12 minutes ago, Nate4x4 said:

Awesome, I hope everything turns out for you.

Thanks for your question.👍

Nate

Thanks for your input!

 

Share this post


Link to post
Share on other sites
47 minutes ago, Kous52 said:

Thanks for your input! 

 

Happy to help! 😀

Edited by Nate4x4

Share this post


Link to post
Share on other sites
59 minutes ago, Nate4x4 said:

Happy to help! 😀

Well...i spoke tooo soon. It turns out my back left tire is completely flat. It wasn't at the time so i didn't notice. I'l have to get that patched up. Not sure what i hit or ran over. First time getting a flat with my car. As for the other sound..not sure if it's my sway bars or something else? Small rattling over bumps.

Share this post


Link to post
Share on other sites
17 hours ago, Kous52 said:

Well...i spoke tooo soon. It turns out my back left tire is completely flat. It wasn't at the time so i didn't notice. I'l have to get that patched up. Not sure what i hit or ran over. First time getting a flat with my car. As for the other sound..not sure if it's my sway bars or something else? Small rattling over bumps. 

Hi again!

Well that's real good to hear (to replace the suspension would have been a lot more expensive). 👀

On 8/29/2018 at 10:08 AM, Kous52 said:

I got brand new tires..with only about 5000 miles on it.

With just 5,000 miles...indeed the only reasonable thing to do would be to patch it up.

 

This is the tire repair kit I used, (worked :D). ⬇️

 

81EGWOeH4KL._SL1500_.jpg

Edited by Nate4x4

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
- Back to Top -

×