RD23

2001 mustang V6 new battery not holding charge? Newish alternator...

1 post in this topic Register to Ask a Question

Recommended Posts

RD23    0

So about a month ago, I replaced my battery because it wouldn't hold a charge after turning off hence it wouldn't turn over nor start. This occurred out of the blue. For for about 2 weeks, it started up just fine after getting the new battery so I figured the problem was solved. Now after a couple weeks of it sitting, I go to start the car and it's completely dead so I jump start it, thinking if I let it run and drive it around, the alternator will re charge and I'll be able to start it again after turning it off. Long story short, that wasn't the case and it's having the same problem it did before I replaced the battery. Also, the alternator is fairly new being replaced about a year ago... It dosnt die while driving, only after turning off. Not enough juice for it to turn over completely. It clicks, and makes an effort but won't turn over enough for it to start. Could it be as simple as terminals needing to be cleaned or more of a wiring issue? I also have very little experience with working on cars, so I'm not quite mechanically inclined. But I'd also rather not spend a bunch of money taking it to a shop, if unnecessary though. Any help would be highly appreciated!

Share this post


Link to post
Share on other sites
Back to Top ↑

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now