Jump to content

1 post in this topic

Recommended Posts

I NEED HELP FAST, PLEASE GIVE ME YOUR IMPUT

 

Okay so I've had this problem for about 2 weeks or so, I own a 2006 Lincoln zephyr, it is a v6, 3.0L, with FWD. After switching the back breaks on my car(new pads, new rotors), i bought 2 used tires, during the install the guy toldme I have abent rim and he will put it in the back so my wheel doesn't shake, after I left the shop I noticed intense vibration on the driver side plus a loud noise as if the tire was loose hitting something and rubbing agains something, went back got it put in the back. I still hear the sound just quiet and in the back, car still vibrates. The car vibrates a little(feeling it when I put my feet on the ground not the pedals) at all time, vibration is sort of under the seat and by the pedals. The car jerks/bumps at really slow speeds (0-15mph) and when I break, but only when I slow down or lightly press the break pedal. When pressed hard it doesn't do that. Every time I start my car it's not that bad but then it gets worst. I know I need my breaks bleeded but could that be the problem?? Or what can it be?

 

 

This has probably nothing to do with it, but I did get subs put in the car recently, and I have noticed a clicking sound comin from the engine. Sounds like maybe one of the valves.

Edited by Maciek77323

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  
- Back to Top -

×
×
  • Create New...